Cannot delete a user from a Databricks account

Contact your account team to change the account owner and then delete the previous account owner.

Written by aishwarya.sood

Last published at: July 18th, 2025

Problem

You are an admin in your Databricks account, trying to delete a user (by email) from the account console. You receive the following error. 

Either missing permissions to delete <email> or deleting own account.

 

Cause

The user you are trying to delete is the owner of the Databricks account. If the to-be-deleted user is not an account owner, you may be instead trying to delete your own account, which is not possible and results in this error.

 

Solution

First verify whether the to-be-deleted user is indeed the account owner and update the account ownership. If you are not sure who your Databricks account owner is, contact Databricks Support to retrieve this information. 

 

To update account ownership, contact your Databricks account team or raise a support ticket to initiate ownership transfer. Once the ownership is updated, you can delete the user.

 

If neither of the causes pertains to you and you continue to encounter the error, contact Databricks Support to help you investigate further.