Cannot start Databricks workspace from Google Cloud console

Check to make sure your Databricks subscription is active and that you are using the correct Google account.

Written by vivian.wilfred

Last published at: December 21st, 2022

Problem

You are not able to launch Databricks workspaces from the Google Cloud console. The button to launch workspaces is grayed out with the message Your subscription is not active.

Cause

You do not have an active Databricks subscription on this Google account.

The most likely cause is the creation of two (or more) trial accounts, with different billing accounts, and with most users in the second account. When the subscription was extended, it was done in the account without the majority of users. For example, your Databricks subscription is on Google account A, while the majority of users are in Google account B.

As a result, the users are directed to the Google account with the inactive Databricks account when they login to the Databricks accounts console.

Solution

The Google account owner should remove the users from the inactive Databricks account and add them to the Databricks subscription in the primary Google account. This can be done in the Databricks account console.