Azure container does not exist error when creating files in a workspace

Make sure the container location and permissions are correct.

Written by prabakar.ammeappin

Last published at: September 12th, 2024

Problem

When attempting to create files in a Databricks workspace, you receive the error:  

'Request failed for POST /<filepath>/<filename>. Cause: The Azure container does not exist'. 

Note 

This issue occurs in the Azure Databricks environment and affects the ability to create normal files, but not the ability to create notebooks. 

 

Cause

There are three possible causes. 

  • The Azure container might not have been properly created when the workspace was provisioned.
  • The Azure container might have been deleted or moved after it was created. 
  • There might be a problem with the permissions or roles assigned to the user or service principal trying to access the Azure container.

Solution

First, confirm the Azure container exists in the specified resource group and subscription. If it has been deleted or moved, recreate it in the correct location.

Then ensure the user or service principal has the necessary permissions to access and create files in the Azure container. Adjust the roles and permissions as needed.

If the workspace is newly deployed and the issue persists, consider deleting and recreating the workspace. This can resolve issues caused by errors during the initial provisioning process.

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