Error “The security token included in the request is invalid.” when trying to access a mount point

Update your mount credential.

Written by zhengxian.huang

Last published at: July 17th, 2025

Problem

When you try to access a mount point – or a table that has data stored under an S3 path that is the same as the mount point – you encounter the following error. 

com.databricks.backend.common.rpc.SparkDriverExceptions$SQLExecutionException: java.rmi.RemoteException: com.amazonaws.services.securitytoken.model.AWSSecurityTokenServiceException: The security token included in the request is invalid. (Service: AWSSecurityTokenService; Status Code: 403; Error Code: InvalidClientTokenId; Request ID: xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null); nested exception is:
com.amazonaws.services.securitytoken.model.AWSSecurityTokenServiceException: The security token included in the request is invalid. (Service: AWSSecurityTokenService; Status Code: 403; Error Code: InvalidClientTokenId; Request ID: xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)

 

Cause

The AWS credential used to create the mount point has expired, and is not able to authenticate the access request.

 

Solution

Update the mount point with a valid credential. For details and instructions, refer to the Mounting cloud object storage on Databricks documentation.