Unable to update a serving endpoint even with necessary permissions

Find the creating user in the workspace and re-add the permissions.

Written by aimee.gonzalezcameron

Last published at: July 29th, 2024

Problem 

You are unable to update a serving endpoint in Databricks, even if you have the necessary permissions. The error message observed is: 'User does not have permission 'View' on Model <model_name>'

 

This issue occurs in the Machine Learning environment when working with serving endpoints and registered models.

Cause

The user who created the registered model-serving endpoint no longer has permissions. Databricks uses a creator’s credentials to determine downstream permissions. 

Important!

When the creator no longer has permissions, neither other users, admins, nor Databricks support will be able to update the endpoint.

 

Solution

If the user still exists in the workspace:  

  1. Re-add the necessary permissions for the user who created the registered model-serving endpoint.
  2. Trigger the update for the model-serving endpoint once the permissions are restored.
  3. Verify that the model-serving endpoint is updated to use the latest model version as required.

If the user is entirely removed from the Account/workspace, please contact Databricks support. 

Note

For production model-serving endpoints, we recommend using a service principal to create model-serving endpoints and upstream assets for consistent update evaluation. As an additional measure, consider registering the model in Unity Catalog (UC) and migrating the model.

 
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