DS_RESOURCE_NOT_FOUND_ON_DS_SERVER error when a data recipient tries to access views from a dedicated cluster

Utilize TOKEN-based sharing.

Written by srihasa.akepati

Last published at: April 28th, 2025

Problem

As a data recipient in Delta Sharing, you are able to access both tables and views from an SQL warehouse or a standard cluster, but you notice you can only access the tables from a dedicated cluster, not the views. You receive the following error. 

HTTP request failed with status: HTTP/1.1 404 Not Found for query(Some(307774b4)).  {"error_code":"NOT_FOUND","message":"DS_RESOURCE_NOT_FOUND_ON_DS_SERVER: Resource not found on sharing server\nEndpoint: https://<sharing-identifier>/api/2.0/delta-sharing/metastores/<metastore-id>/shares/<share-name>/schemas/<schema-name>/tables/<view-name>/query\nMethod: POST\nHTTP Code: 404\nStatus Line: 404\nBody: {\"error_code\":\"TABLE_DOES_NOT_EXIST\",\"message\":\"Table '<catalog-name>.<schema-name>.__dsff_materialization_<view-name>_XXXXXX' does not exist.

 

Cause

The materialization of the views occurs on the workspace where the recipient was created, but the recipient does not have access to the underlying share due to catalog bindings.

This behavior discrepancy is due to the way Delta sharing handles materialization and access control for shared catalogs.

 

Solution

  1. Create a TOKEN recipient on the data provider side. Navigate to the Delta Sharing page > Shared by me tab > Recipients > New recipientCreate Open recipient with Token authentication
  2. Share the TOKEN profile with the recipient. Use the activation link generated from Step 1 to download the TOKEN profile (credential file)
  3. Have the recipient create a data provider using the TOKEN profile. On the Delta Sharing providers page, under the Shared with me tab, click the Import data button on the righthand side. The following screenshot shows the UI with the Import data button location and style.
  4. Mount the catalog using the share.