User not found error while trying to install a library on a shared cluster

Change cluster ownership and reconfigure all libraries under the new owner.

Written by guruprasad.bn

Last published at: December 3rd, 2024

Problem

When trying to install a library using the UI on a shared cluster, you encounter a USER_ID_NOT_FOUND_FAILURE error. 

 

"Library installation failed after PENDING for 0 minutes since the cluster entered the RUNNING state. Error Code: USER_ID_NOT_FOUND_FAILURE. Library installation failed on cluster <cluster-ID> due to an invalid user. Please reinstall the library."

 

Cause

For shared clusters, the library installer's identity determines whether the user has permission to install libraries on clusters and access the library files. 

Changing a shared cluster’s ownership away from a deleted user to an active user doesn’t resolve access issues because the library installer’s identity is still set to the deleted user. The library installer’s identity is no longer valid in the workspace's cluster libraries database.

 

Access Mode

Installation Identity 

Installation identity  before ownership change  

Installation identity  before ownership change to User B

Shared

Installer’s identity

User A (Installer’s identity)

User A (Installer’s identity)

 

Solution

Change the ownership of the cluster to a different, active user in the workspace. Then, reconfigure desired libraries to match the new owner.   

  1. Delete all libraries from the cluster.
  2. Terminate the cluster.
  3. Start the cluster.
  4. Reinstall each library one by one.