Problem
When you try to access your workspace, you receive a server error saying the site can’t be reached. The following image shows the error from the browser UI.
Cause
The workspace is using a custom DNS that does not match the hostname IP address.
Solution
- First, obtain the custom DNS CIDR from your cloud console.
- From the terminal, run
nslookup
on your hostname.
%sh
nslookup <hostname>
- Next, ensure the hostname is resolving to the IP address matching the DNS server records you checked in step 2.
- Ensure your IP and the configured IP from the custom DNS server match. Otherwise, point your host to the proper DNS classless inter-domain routing (CIDR).