Tag removal is not propagated on compute restart

Manually edit the compute and make a temporary or small change for tags to update.

Written by jose.salgado

Last published at: July 25th, 2025

Problem

The tags you remove from your Azure cloud resource do not propagate correctly to your workspace compute resources. The tag is still present in the workspace compute even after a restart.

 

Cause

There is a synchronization failure between the cloud resource and the workspace compute. 

 

Solution

Manually edit your compute resource. Perform a minor, temporary change such as adding a dummy tag or a small change on the cluster name. 

  1. Navigate to Compute in the sidebar. 
  2. Select the impacted cluster. 
  3. Click Edit
  4. To make a tag change, scroll down to the Tags section. 
  5. Add a temporary tag or change the value of an existing one and then change it back.
  6. Click Confirm at the bottom of the page.

 

Alternatively, to make a name change, in step 4 instead of scrolling to the Tags section, click in the Compute Name field and make a minor change, such as an extra space at the end. Continue with step 6. 

 

The compute-side change forces the tags to synchronize with the cloud resource and reflect the correct tags.