Getting dashboard download successful message but not downloading

Validate the browser restrictions and work with your organization’s IT team to allow Databricks dashboard export.

Written by vidya.sagamreddy

Last published at: July 25th, 2025

Problem

When you export a Databricks SQL Analytics dashboard, you see a message that the export was successful, but the dashboard doesn’t seem to have downloaded. 

 

Cause

Your organization may have a browser policy restricting downloads. 

 

Solution

First, choose your respective browser from the following list and following the steps to navigate to the browser policy. Current version refers to the most up to date version as of July 2025. 

 

Google Chrome (current version)

  1. Open Chrome.
  2. Go to: chrome://policy
  3. In the list of active policies, look for download-related keys.

 

Mozilla Firefox (current version)

  1. Open Firefox.
  2. Go to: about:policies
  3. Refer to the Active tab for relevant download policies.

 

Microsoft Edge (current version – Chromium-based)

  1. Open Edge.
  2. Go to: edge://policy
  3. Look for download-related policies. 

 

Apple Safari (current version – macOS only)

Safari doesn’t have an internal policy viewer, but download behavior can be restricted by system-managed preferences (mobile device management (MDM) profiles or Terminal settings).

  1. Open Terminal.
  2. Run:
defaults read com.apple.Safari

 or

 /usr/bin/profiles show -type configuration

 

  1. Look for download keys. 

 

Then, verify whether you have browser policies in place that restrict downloads. Consider adjusting them to allow downloads for Databricks or specifically for the domain used by Databricks in your organization.

 

Last, reach out to your organization's security or IT team to understand the current browser policies enforced within your organization. Discuss the requirement to export dashboards from Databricks and see if the policies can be adjusted to accommodate this functionality.