Members of a Gmail group email not receiving notifications

Allow external entities to email the group inbox.

Written by walter.camacho

Last published at: September 18th, 2024

Problem 

When using Gmail group notifications for job executions, the set of users belonging to the group do not receive the notifications. Other email clients are not affected. 

Cause

The group’s incoming email setup does not permit messages from outside the organization.

Solution

Allow external entities to email the group inbox. 

  • Log into your Google Workspace Admin console. 
  • Go to Apps / Google Workspace / Groups for Business / Sharing settings.
  • Check Group owners can allow incoming email from outside the organization.
  • Click Save.

 

If your group already exists, then you also need to make a change within the specific group’s settings.

  • Navigate to Google groups and click the group that needs to receive notifications.
  • Click on Group settings and scroll down the page.
  • Change ‘Who can post’ to ‘Anyone on the web’ and click Save changes.