Problem
When you try to run a job, it fails with the following error indicating the job cannot access the indicated notebook.
Unable to access the notebook "</folder/subfolder/notebook-name>". Either it does not exist, or the identity used to run this job, <identity>, lacks the required permissions.
Cause
The notebook was either deleted or renamed, or its permissions were changed.
Solution
- Review the notebook path to verify whether the notebook exists.
- Review the notebook's permissions. If any user or service principal permissions required to run the job are missing, update them and retry the job.
- If you still encounter the error, check the audit logs system table to see actions performed on this notebook, such as a renaming. You can use the following script to fetch notebook-related audit logs.
%sql
select * from system.access.audit
where service_name = "notebook"
and event_date = "yyyy-mm-dd"
and request_params.notebookId like "<notebook-id>"
- Update the job’s notebook path config accordingly.
For more information, review the Audit log system table reference (AWS | Azure | GCP) documentation. Before accessing the system table, review the requirements in the Monitor account activity with system tables (AWS | Azure | GCP) documentation.