Job failing with error “Unable to access the notebook”

Verify the notebook path and permissions, update the permissions and retry the job.

Written by aishwarya.sood

Last published at: October 15th, 2025

Problem

When you try to run a job, it fails with the following error indicating the job cannot access the indicated notebook. 

Unable to access the notebook "</folder/subfolder/notebook-name>". Either it does not exist, or the identity used to run this job, <identity>, lacks the required permissions.

 

Cause

The notebook was either deleted or renamed, or its permissions were changed.

 

Solution

  1. Review the notebook path to verify whether the notebook exists. 
  2. Review the notebook's permissions. If any user or service principal permissions required to run the job are missing, update them and retry the job.
  3. If you still encounter the error, check the audit logs system table to see actions performed on this notebook, such as a renaming. You can use the following script to fetch notebook-related audit logs. 
%sql
select * from  system.access.audit
where service_name = "notebook"
and event_date = "yyyy-mm-dd" 
and request_params.notebookId like "<notebook-id>"
  1. Update the job’s notebook path config accordingly. 

 

For more information, review the Audit log system table reference (AWSAzureGCP) documentation. Before accessing the system table, review the requirements in the Monitor account activity with system tables (AWSAzureGCP) documentation.